---
title: "Connect to Vicon Datastream"
canonical: "https://help.vicon.com/space/Unreal5Plugin18/14845980/Connect%20to%20Vicon%20Datastream"
format: markdown
---
This page covers how to connect to a Vicon Datastream within Unreal Engine. This involves creating a Link Link source and there are several ways to do this, all of which are covered in the following sections.

> Macro (toc)

## Prerequisites

To create a Live Link source, ensure you have set up and installed the following components:

- 1 x PC with Vicon software (Shogun) installed
  - You will need the IP address of this PC
- 1 x PC with Unreal Engine 5 (UE5) installed
- Vicon Live Link Datastream plugin is installed and enabled on Unreal Engine 5 (see [Install and set up Live Link](https://vicon-help.atlassian.net/wiki/spaces/Unreal5Plugin18/pages/14844159))
- The PCs are connected via LAN
- An Unreal Engine 5 project is open

> Macro (anchor)



## Connect to Vicon Datastream using Live Link

1. Open Unreal Engine 5 and open a project.
2. Go to **Window** > **Virtual Production **> **Live Link**.
3. Click **Source** and select **Vicon Datastream Source**.
4. In the **Vicon Server Name** field, enter the IP address of the Vicon machine.
5. In the **Port Number** field, enter 801 (the Vicon default) or 804 (the Evoke Low Latency output or Shogun Always Live output). For more information, see [Unreal Plugin source machine settings](https://vicon-help.atlassian.net/wiki/spaces/Unreal5Plugin18/pages/14845083).
6. Click **Create** to create the Live Link connection.

The Live Link connection is now displayed in the **Source** pane of the Live Link dialog box, with the subjects displayed in the **Subject** pane.

![image](media://74519775-17c1-4911-ba8d-70a610219f7d)

## Connect to Vicon Datastream using blueprint functions

Connecting to a Vicon Datastream using blueprint functions involves the following stages:

> Macro (toc)

### Create a new blueprint

1. Open Unreal Engine 5 and open a project.
2. Go to **Window** > **Content Browser **> **Content Browser 01**.
3. In the content browser window (or dialog box), click **Add**.
4. Under **Create Basic Asset**, click **Blueprint Class**.
5. In the dialog box, select **Actor** so that it can be spawned or placed in the level.
6. Name the actor blueprint and add it to your project.
7. In the new blueprint dialog box, in the toolbar along the top, click **Event Graph**.

### Set up the blueprint function

1. In the new blueprint dialog box, right-click an empty space in the graph to create a new node.
2. In the **All Actions for this Blueprint** dialog box, search for **Create Vicon Live Link Source**.
3. Select **Create Vicon Live Link Source** to spawn a node in the graph.
4. Connect an event trigger to the input of the node. This example uses the event **EventBeginPlay** as this creates a Live Link connection when play starts.
5. Enter the following parameters into the Link Link node:
  - The IP address of the Vicon machine.
  - In Port Number enter either - *801* (the Vicon default) or *804* (the Evoke Low Latency output or Shogun Always Live output).
6. Compile and save the blueprint.
7. Drag the blueprint from the content browser directly into the level.

> ✅ **Tip**  
> ✅ When a source has been created, it continues to exist until it is manually removed, so you may accidentally create multiple sources during your work. Ensure the final node graph looks like this screenshot:  
> ✅   
> ✅ > Macro (inline-media-image)

> Macro (scroll-pagebreak)

### Check the source has been created successfully

1. With the blueprint placed in the level, go to the toolbar at the top and click **Simulate**.
2. Go to **Window** >**Virtual Production **>**Live Link**.
3. In the **Source** panel, check that a source has been successfully created.
4. Go to **Window** >** Developer Tools** > **Output Log**.
5. Ensure the output log reports the same input parameters for Unreal Engine and the source at creation.

## Connect to Vicon Datastream using Live Link Presets

Connecting to a Vicon Datastream using Presets involves the following stages:

> Macro (toc)

#### Create a Preset in Unreal Engine

1. Create a Live Link source in Unreal Engine. For more information, see [Connect to Vicon Datastream using Live Link](#ConnectToViconDatastreamUsingLiveLink).
2. When an active Live Link source has been created, in the Live Link dialog box, click the **Presets** button next to **Add Source**.
3. Click **Save As Preset** and enter an appropriate name.

#### Add a source to the Preset

1. Remove all existing Live Link connections.
2. Click the **Presets** button.
3. Select the preset you just created.
4. After selecting the preset, click on the Source panel to ensure the Live Link source has been added to the preset.

#### Add a Source to a project using the Preset

1. Go to **Edit** > **Project Settings**.  
  
> Macro (inline-media-image)
2. In the search bar, enter `Live Link`.
3. Under **Plugins - Live Link**, go to the **Default Live Link Preset**.
4. Select the preset you just created.
5. Restart your project.

After you have restarted your project, check the Live Link connection has been created.