---
title: "Connect to Vicon Datastream using blueprint functions"
canonical: "https://help.vicon.com/space/Unreal5Plugin113/1152057364/Connect%20to%20Vicon%20Datastream%20using%20blueprint%20functions"
format: markdown
---
Connecting to a Vicon Datastream using blueprint functions involves the following stages:

> Macro (toc)

### Create a new blueprint

1. Open Unreal Engine 5 and open a project.
2. Go to **Window** > **Content Browser **> **Content Browser 01**.
3. In the content browser window (or dialog box), click **Add**.
4. Under **Create Basic Asset**, click **Blueprint Class**.
5. In the dialog box, select **Actor** so that it can be spawned or placed in the level.
6. Name the actor blueprint and add it to your project.
7. In the new blueprint dialog box, in the toolbar along the top, click **Event Graph**.

### Set up the blueprint function

1. In the new blueprint dialog box, right-click an empty space in the graph to create a new node.
2. In the **All Actions for this Blueprint** dialog box, search for **Create Vicon Live Link Source**.
3. Select **Create Vicon Live Link Source** to spawn a node in the graph.
4. Connect an event trigger to the input of the node. This example uses the event **EventBeginPlay** as this creates a Live Link connection when play starts.
5. Enter the following parameters into the Link Link node:
  - The IP address of the Vicon machine.
  - In Port Number enter either - *801* (the Vicon default) or *804* (the Evoke Low Latency output or Shogun Always Live output).
6. Compile and save the blueprint.
7. Drag the blueprint from the content browser directly into the level.

> ✅ **Tip**
> ✅         
> ✅ 
> ✅ When a source has been created, it continues to exist until it is manually removed, so you may accidentally create multiple sources during your work. Ensure the final node graph looks like this screenshot:
> ✅ 
> ✅ ![image](media://ded3129a-e33a-40ca-9d62-8ec7ebd7ff5c)

### Check the source has been created successfully

1. With the blueprint placed in the level, go to the toolbar at the top and click **Simulate**.
2. Go to **Window** >**Virtual Production **>**Live Link**.
3. In the **Source** panel, check that a source has been successfully created.
4. Go to **Window** >** Developer Tools** > **Output Log**.
5. Ensure the output log reports the same input parameters for Unreal Engine and the source at creation.