---
title: "Menu bar"
canonical: "https://help.vicon.com/space/Nexus215/11376489/Menu%20bar"
format: markdown
---
The Nexus menu bar contains the following controls.

> Macro (scroll-only)
> 
> > Macro (toc)

## File menu

The **File** menu contains the following options:

- **Save** (shortcut CTRL+S) Saves the current data for subjects enabled in the **Subjects Resources** pane to the .c3d file for the current trial.
- **Copy As** Displays the **Choose a c3d file** dialog box in which you can enter or select the name of the file to copy to. Makes a copy of the current trial .c3d, .vsk, and .mp files. Using this feature, you can archive copies of a .c3d file to document its processing progression.
  :check_mark: **Tip**   
You are prompted to save the copy in the same location in the **Data Management** hierarchy as the original file, and after saving it will be available in the **Data Management** pane.
- **Import XCP** Displays the **Choose an XCP file** dialog box in which you can select the desired Vicon camera calibration parameters (.xcp) file to load in Nexus. Use this command to import .xcp files created in Vicon Nexus.
- **Export XCP** Displays the **Choose an XCP file** dialog box in which you can specify a calibration parameters (.xcp) file into which to export the current Vicon camera settings. Use this command to export .xcp files created in Vicon Nexus.
- **Exit** Closes the Vicon Nexus application window. If you have not saved any changes made to trial data, Nexus displays a prompt to enable you to save changes to trial data, subjects, or both, before it closes.

## Edit menu

The **Edit** menu contains the following options, which take effect only when the system is in Pause or Offline mode:

- **Undo** (shortcut CTRL+Z) Undoes the last action. This command is available only after a relevant action has been performed. The name of the Undo command changes to reflect the latest action, for example, **Undo Import XCP**. You also can hover the mouse pointer over the Undo button to display a tooltip that identifies the action to be undone. Some actions, such as reconstructing data, cannot be undone.
- **Redo** (shortcut CTRL+Y) Reinstates the previously undone action. This command is available only after an **Undo** command has been performed. The name of the **Redo** command changes to reflect the latest action, for example, Redo Import XCP. Hover the mouse pointer over the **Redo** button to display a tooltip that identifies the action to be redone. Any action that was undone can be redone.

> Macro (scroll-pagebreak)

## Window menu

The **Window** menu contains the following options:

- **Simple Capture Mode** (shortcut CTRL+H). Displays a window containing only the minimum of controls necessary for capture, facilitating the capture of multiple trials. See [Use Simple Capture Mode](https://vicon-help.atlassian.net/wiki/spaces/Nexus215/pages/11379021) in the *Vicon Nexus User Guide*.
- **New floating workspace**. Opens a separate floating view pane. See [View pane](https://vicon-help.atlassian.net/wiki/spaces/Nexus215/pages/11381133).
- **Reset to default layout** Resets the Nexus panes to their layout when Nexus was installed.
- **Toolbar** Opens the **Customize Toolbar** dialog box, in which you can add, remove, and customize buttons on the Nexus toolbar. See [Customize Toolbar dialog box](https://vicon-help.atlassian.net/wiki/spaces/Nexus215/pages/11380156/Toolbar#dlgCustomizeToolbar).
- **Quick Reports** (shortcut F4) Opens a Quick Reports window, in which you can display multiple graphs of model outputs. See [Quick Reports](#QuickReports).
- **Sounds** (shortcut F6) Opens the **Sounds** dialog box, in which you can view or change the sounds that are used to alert you to Nexus events. You can also turn off the sounds individually or turn off all sounds. See [Sounds dialog box](#dlgSounds).
- **Options** (shortcut F7) Opens the Options dialog box, in which you control how data is displayed. See [Options dialog box](#dlgOptions).
- **Plug-ins** Displays the **Plugins** dialog box in which you can view and manage plug-in modules that are loaded in Vicon Nexus. If you clear the checkboxes for Theia, MATLAB, Python, etc, their plug-ins are not loaded and their tabs are not displayed in the **Communications** pane.
- **Manage Control Authorizations** Opens the **Vicon Control** dialog box, where you can authorize or revoke authorizations for instances of Vicon Control that are connected to the Vicon system. See [Vicon Control dialog box](#dlgControl).
- **Footstrike Monitor Settings** Lets you set options for foot strike monitoring. See [Automatically assess foot strikes](https://vicon-help.atlassian.net/wiki/spaces/Nexus215/pages/11376087) in the *Vicon Nexus User Guide*.
- **Close Communications Pane on Trial Load** Enables you to show or hide the **Communications** pane when you load a trial. If selected, the **Communications** pane is minimized at the bottom of the Nexus window the next time you load a trial. The **Communications** pane stays hidden until you double-click one of the tabs at the bottom of the **Communications** pane. Your choice for this option is retained when you exit and restart Nexus. It can be set as required by each Nexus user.
- **Error Message Settings** Opens the **Error Settings** dialog box, where you can adjust the length of time that popup notifications are displayed and the maximum number of notifications that are displayed. See [Error Settings dialog box](#dlgErrorMsg).

### > Macro (anchor)

Quick reports

The **Nexus Quick Reports** window enables you to display multiple graphs of model outputs normalized over the gait cycle (like a simplified Vicon Polygon graph view).

![image](media://849fe9ca-cc41-42e5-a1d7-a04caeca7b3f)


**To display model outputs in Nexus Quick Reports:**


1. On the **Window** menu, click **Quick Reports**, or press F4 to open the **Nexus Quick Reports** window.
2. In the main Nexus window, ensure that the trial (*.C3D file) that you want add to Quick Reports is the current trial.
3. From the **Pipeline Tools** pane, expand **Data Processing** and double-click **Add Trial to Quick Report** to add it to the current pipeline.
4. In the **Current Pipeline** list, right-click the **Add Trial to Quick Report** operation and click **Run select Op**.
5. For each trial that you want to add, repeat step 2–4.
  :check_mark: **Tip**   
To add trials to Quick Reports, you can also:
  - Drag and drop one or more trials (*.C3D files) from Windows Explorer into the **Quick Reports** window; or
  - Click the **Add To Quick Report** button on the Nexus toolbar (adds the current trial); or
  - On the **Data Management** tab, mark the required files and in the Quick Reports window, click **Import Marked**.
6. In the Nexus **Quick Reports** window, the added trials are displayed in the **Trials** list, by default on the right of the window.
7. From the **Display Mode** list, select the required option.
  - **Single** Displays either one context (Left or Right) or both (Left and Right) for a specific cycle, for example: Left = Cycle 1, right = Cycle 1. This option displays data as a normalized gait cycle 0-100.
  - **Overlaid** Displays either one context (Left or Right) or both (Left and Right) for all cycles. This option displays data as a normalized gait cycle 0-100.
  - **All** Displays either one context (Left or Right) or both (Left and Right) for all cycles. This option displays data as frames and is not normalized, in a similar way to the previous All cycles feature in Quick Reports.
8. Ensure the required cycle is selected in the **Left** and **Right** columns.
  :check_mark: **Tip**   
To change the options for all the trials, in the **Trials** section, click the appropriate option at the top of the columns.  
> Macro (inline-media-image)
9. To display model outputs in the graphs, in the **Model Outputs** list, expand the relevant node and then select the required check box(es).
  The selected outputs are displayed as graphs in the **Nexus Quick Reports** window.
  To display only the required components, in the **Model Outputs** tree, clear the check boxes for the unwanted components.  
For example, if you are interested in AnkleMoment X only, you can select this only.
  :check_mark: **Tip**   
By default a red line represents data from the left side and a green line represents data from the right. The trial currently selected in the **Report Options** list is represented by a heavier line on the graphs. To change green and red to solid and dashed lines, in the **Options** dialog box (press F7), on the left, click **Quick Reports** and then clear **Use Context Colors**. To change the colors displayed for each trace on the graph, click the color(s) that you want to change.
10. Expand the **Gait Cycle Analysis** section at the bottom left of the window and ensure the **Distance Markers** and **Units** are as required.
  :check_mark: **Tip**   
If the nodes are not expanded, the  **Parameter**  column displays average values (in bold) across all selected trials. To view the average value for each trial, ensure the relevant parameter nodes are expanded.
11. To export a PDF of the data in the **Nexus Quick Reports** window:
  1. Expand the **Export Options** section and clear or select as required.
  2. From the **Title Alignment** list, select the required option.
  3. Click **Export** and in the **Export to PDF** dialog box, enter or browse to the required location.
  4. Click **Save**.
12. To save your work, click the **Save** button at the bottom of the **Report Options** pane and select the appropriate option:
  - *. * qrd * (Quick Reports Document): Saves the current Quick Report. Select this option if you have to suspend work on the report and want to carry on where you left off later.
  - *. * qrt * (Quick Reports Template): Saves the layout of the ** Nexus Quick Reports ** window (ie the options currently selected in the Quick Reports window). Select this option if you want to produce reports of the same type of information for later trials. Quick Reports templates that are saved to the default location:  
*C:\Users\Public\Documents\Vicon\Nexus2.x\Configurations\QuickReports*   
are listed when you click the ** Apply Report Template ** button > Macro (inline-media-image)

.

#### About the Nexus Quick Reports window

The **Nexus Quick Reports** window comprises two sections:

- Controls are contained in a dockable **Report Options** pane, which by default is displayed to the right of the window. Expand the **Trials**, **Model Outputs** and** Export Options** sections by clicking the downward arrow to the right of each section divider. To move the controls pane, drag the **Report Options** title. The pane can be floated or docked to the left or right.
- Graphs of the data selected in the **Report Options** pane are shown in the main workspace. The current subject’s name and model template are shown as a title at the top.

To the bottom left of the main workspace, **Gait Cycle Analysis** parameters for the loaded trials are displayed.

In the large text box on the right, you can enter a description or notes, etc, which can be formatted using the buttons on the toolbar above the text box.

To close the **Nexus Quick Reports** window, press F4.

> Macro (scroll-pagebreak)

##### Report Options controls

In the **Report Options** pane, the following controls are available:

> Macro (scroll-tablelayout)

| **Control** | **Description** |
| --- | --- |
| **Subject** field | Enables you to select the subject whose data you want to view. |
| **Trials** list | Lists the trials that you have added to the report. In this list, you can select or clear the relevant check boxes to display the required trial(s). To show/hide all trials, expand the **Trials** section and select or clear the check box at the top. The outputs for selected trials are displayed in each graph.  
The **Cycle** dropdown lists at the top and in the **Left** and **Right** columns of the **Trials** list enable you to select which gait cycles to show for the left and right contexts for each trial.  
To select trials, click (or Shift+click/Ctrl+click) in the **Trial **column of the required row(s) in the list. The selected row(s) in the list are highlighted with a blue background and by thicker lines in the graph.  
To remove selected trials from the report or to mark selected trials in **Data Management** (eg, for use in Vicon Polygon), click **Remove Selected** or **Mark Selected **at the bottom of the list. |
| **Model Outputs** list | Displays available model outputs from the trials that have been added to the report. |
| **Export** button | Opens the **Export to PDF** dialog box, which enables you to save the contents of the current **Nexus Quick Reports** window to a *.PDF file, with a name and location that you specify. |
| **Save** button | Enables you to save the current Quick Report either as a document (*.*qrd*) or a template (*.*qrt*). |
| **Open** button | Enables you to enter or browse to aQuick Report document (*.*qrd*) or a template (*.*qrt*). |
| **Apply Report Template** button > Macro (inline-media-image) | Enables you to apply a report template that was saved to the default location (*C:\Users\Public\Documents\Vicon\Nexus2.x\Configurations\QuickReports*). |

> Macro (scroll-pagebreak)

### > Macro (anchor)

Sounds dialog box

Nexus can play sounds through your PC's speakers to alert you when a Nexus event has taken place (for example, operation completion, system status, and issues). This keeps you informed of system status while you're still in the volume, so that you don't have to spend time returning to the PC to look at the screen.

You can access this dialog box from the **Window** menu or by pressing F6.

By default, Nexus uses speech sounds to alert you to the following events<span style="color: #003300">:</span>

- Calibration start
- Wand Wave complete
- Calibration complete
- Calibration failed
- Origin set
- Capture started
- Capture ended
- Capture failed
- Camera bumped
- Pipeline ended
- Pipeline failed

Nexus is supplied with a set of default sound files (.wavs). You can modify the sounds that are used for each event and you can turn off sounds individually or turn off all sounds.

To turn off all sounds, in the **Sounds** section, clear the **Enabled** check box.

To turn off one or more sounds, click the relevant drop-down arrow and select (None) from the list.

To choose one of the other sounds supplied with Nexus, click the drop-down arrow and select the required sound from the list.

To substitute your own sounds for those supplied with Nexus, click the relevant ellipsis (...) and enter or browse to the location of the required .wav files.

> Macro (scroll-pagebreak)

Use the configuration management area at the top of the **Sounds** dialog box to name, to save, delete and if necessary protect the sounds that you have allocated to Nexus events. After you have saved sounds configuration files, you can select them from the menu at the top of the dialog box and can use the **Configuration menu** to manage them.

![image](media://94a0af9a-8335-47b8-831c-4f08959f7efc)

The sounds configuration file (*.*AudioScheme*) is saved into an *AudioSchemes* folder, in the same location as other Nexus configuration files (see [Manage configurations in Vicon Nexus](https://vicon-help.atlassian.net/wiki/spaces/Nexus215/pages/11375284) in the *Vicon Nexus User Guide*). 

> Macro (scroll-pagebreak)

### > Macro (anchor)

Options dialog box

The **Options** dialog box enables you to control the way data is visualized in the view panes . You can access this dialog box from the **Window** menu or by pressing F7.

The **Options** dialog box includes a configuration area:

![image](media://60048edd-7aca-4425-be3a-be00b1509274)

This enables you to save any changes you make in the **Options** dialog box to a configuration file, with the extension **.Options**. You can then re-use your saved configuration file as required, for example, you could save a different set of options for each type of motion capture application that you use.

In addition to creating customized **Options** configurations, the **Configuration** menu button enables you to rename, import, reload and delete configurations, and refresh the list.

> Macro (scroll-pagebreak)

 


**To configure settings in the Options dialog box:**


1. Open the **Options** dialog box in either of these ways:
  - Click the **Window** menu and then click **Options;** or
  - Press F7.
2. In the list of options on the left side of the dialog box, click an option whose properties you wish to view or change. You can now:
  - Select the check box to switch on the functionality or clear the check box to switch off the functionality for the option.
  - In the **Properties** section on the right side of the dialog box, view or change settings as desired for any available properties. (To see additional settings that may be available for an option, click Show Advanced.)
3. Repeat step 2 for each property whose settings you wish to configure.
4. To save your settings, do one of the following:
  - To save your settings as the current configuration and close the **Options** dialog box, click **Close**; or
  - To give your configuration a name, so that you can easily find it for re-use later, click the Configuration menu button, then click **Save As**, enter a name in the dialog box, click OK, and then choose whether to save your configuration as **Shared** or **Private**.

### > Macro (anchor)

Vicon Control dialog box

To open the **Vicon Control** dialog box, on the **Window** menu, select **Manage Control Authorizations**.

The **Vicon Control** dialog box enables you to carry out the following operations:

- To grant unprompted access in future, ensure the relevant device's check box is selected in the **Known Devices** list.  
In future, the device will be able to connect without having to be re-authorized.

- To permanently revoke access, clear the device's check box in the **Known Devices** list.  
The device is disconnected and in future, it will not be able to connect. This is useful if you accidentally authorized a device, or if you need to remove an authorized device from the system, for example, if it is lost or sold.

- To remove a connected device from the **Known Devices** list and force re-authorization on the next attempt to connect, select the device and then click **Forget Device**.  
To reconnect, the device will have to send an authorization request and be re-authorized.
- To remove all connected devices from the **Known Devices** list and force re-authorization on the next attempt to connect by any of the listed devices, click **Forget All**.

### > Macro (anchor)

Error Settings dialog box

The **Error Settings** dialog box enables you to adjust the length of time that popup notifications are displayed and their maximum number.


**To control popup notifications:**


1. On the **Window** menu, select **Error Message Settings**.
2. In the **Error Settings** dialog box:
  1. Change **Popup timeout** to the length of time (in seconds) that you want the messages to be displayed, up to a maximum time of 10 seconds.  
Note that if you set **Popup timeout** to 0, the error message remains unless you either click on the message or the **Max Errors to Show** is reached, when this error message is automatically removed.
  2. Change **Max Errors to Show** to the number of error messages that you want to be displayed at any one time, up to a maximum of 10 messages.
    The default popup timeout is 5 seconds and the default number of messages is 5.
    If more errors occur within the ** Popup timeout ** period, the oldest error is removed from thetop of the stack andnewest is displayed at thebottom of the stack.

To open the Log, click on any of the error messages. 

> Macro (scroll-pagebreak)

## Help menu

The **Help** menu contains the following commands:

- **View latest help from vicon.com** Displays the most recent version of the live online help.
- **View installed help** Displays the help file (PDF) that was installed with Vicon Nexus.
- **Check for updates** Detects whether any Nexus updates are available.
- **Check for firmware updates** The **Checking Firmware Version** dialog box displays information about the latest released firmware version. See also [Update firmware](https://vicon-help.atlassian.net/wiki/spaces/Nexus215/pages/11379038/Configure+Vicon+hardware+in+Nexus#UpdateFirmware) in the *Vicon Nexus User Guide*.
- **About Vicon Nexus** Displays the Vicon Nexus startup screen, in which you can view version and license server information about the installed release of Nexus.
- **Hotkeys** Displays a list of Nexus shortcuts and hot keys.
- **Vicon Product Licensing** Displays the Vicon Product Licensing tool, which enables you to manage your Vicon product licensing.